您现在的位置:主页 > 行情 >

通达信macd放大倍数

更新时间:2021-09-15 09:28:06

  求高手编写一个通达信MACD指标公式,要把每一小段的面积用数字表示出来

   晕哦,这个用处大么我不回编,但是我可以告诉你原理,取值以后乘以绿柱或者红烛的数量相加,中间要用到判断红绿柱的大小,就是diff和dea的大小。呵呵,正值和负值的区别。呵呵,希望有用。
用别人的
送你个自写的缠中说禅的macd指标
我编制的通达信公式是这样的:
参数:short 默认是12,范围你自己定(下同)
long默认是26;
mid默认是9;
K默认是0,范围0-1,0是显示均线是显示macd面积
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
DIFF:=SUM(MA1-MA2,0);
SUMMACD:=SUM(MACD,0);
W1:=BARSLAST(CROSS(MA2,MA1))+1;
W2:=BARSLAST(CROSS(MA1,MA2))+1;
W3:=BARSLAST(CROSS(MACD,0))+1;
W4:=BARSLAST(CROSS(-MACD,0))+1;
趋势力度:IF(K,SUMMACD-REF(SUMMACD,MIN(W3,W4)),DIFF-REF(DIFF,MIN(W1,W2)));
趋势平均力度:趋势力度/IF(K,(MIN(W3,W4)+1)/20,(MIN(W1,W2)+1)/20),COLORSTICK;
MAX趋势平均力度:HHV(趋势平均力度,34);
MIN趋势平均力度:LLV(趋势平均力度,34);
想看均线,趋势力度就指的均线的面积,平均力度就很明显了
想看macd的面积就把K调成1,趋势力度就指的是macd的面积了。
后面两个值是最近的趋势平均力度的最大最小值,后面的34你看着定,做成一个参数也成。 通达信中,成交量成倍放大公式怎样写

   成交量成n倍放大公式:(n可是1;2;3。。。。等。)
v>ref(v,1)*n; 请高手编一个通达信MACD的DIF快线轴线且成交量略微放大的的选股公式,谢谢。

   SHORT:=12;LONG:=26;MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
XG:CROSS(DIF,0) AND VOL>MA(VOL,5);
{上面是按你说的选股公式,成交量我是取今日成交量大于5日平均成交量写的,
但我觉得这个公式实用性不大,MACD的用法一般都是DIF上穿DEA比较好} 找到个MACD面积的通达信公式, 但放到同花顺里不认, 请问应该如何改

   //{周期放大开关:1为普通模式,0为放大模式}
倍数:=IF(PERIOD=11,1,IF(PERIOD=10,4,IF(PERIOD=9,6,IF(PERIOD=8,10,IF(PERIOD=7,12,IF(PERIOD=6,5,IF(PERIOD=5,5,IF(PERIOD=4,4,IF(PERIOD=3,8, IF(PERIOD=2,4, IF(PERIOD=1,6,IF(PERIOD=0,5,1))))))))))));
N1:=IF(周期放大,12,12*倍数);
N2:=IF(周期放大,26,26*倍数);
N3:=IF(周期放大,9,9*倍数);
DIFF:EMA(CLOSE,N1) - EMA(CLOSE,N2),colorwhite,NODRAW;
DEA:EMA(DIFF,N3),coloryellow,NODRAW;
MACD: (DIFF-DEA)*2,COLORSTICK,NODRAW;
红柱面积:IF(MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),NODRAW,colorred;
绿柱面积:ABS(IF(MACD<0,SUM(MACD,BARSLAST(MACD>0)),0)),NODRAW,colorligreen;
MACD面积:=IF(MACD>0,红柱面积,绿柱面积),NODRAW,COLORFFFF00;
位置:=MAX(HHV(DIFF,100),ABS(LLV(DIFF,100)));
//{柱变与交叉临界}
开盘价格:=O,coloryellow,NODRAW;
收盘价格:=C,coloryellow,NODRAW;
最高价格:=H,coloryellow,NODRAW;
最低价格:=L,coloryellow,NODRAW;
振幅:=(H-L)/REF(C,1)*100,coloryellow,NODRAW;
柱变临界:REF((EMA(CLOSE,12)*1134-EMA(CLOSE,26)*910-DEA*702)/224,1),colorlimagenta,NODRAW;
交叉临界:351/28*(EMA(REF(DIFF,1),9)-11/13*EMA(REF(C,1),12)+25/27*EMA(REF(C,1),26)),colorlimagenta,NODRAW;
明日柱变临界: (EMA(CLOSE,12)*1134-EMA(CLOSE,26)*910-DEA*702)/224,colorliblue,NODRAW;
明日交叉临界:351/28*(EMA(DIFF,9)-11/13*EMA(C,12)+25/27*EMA(C,26)),colorliblue,NODRAW;
//{MACD重建-避免遮挡}
STICKLINE(MACD>0,0,MACD,1,0),colorred;
STICKLINE(MACD<0,0,MACD,1,0),colorgreen;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),0,MACD,1,0),coloryellow;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1,0),colorwhite;
NOTEXTDIFF:EMA(CLOSE,N1) - EMA(CLOSE,N2),colorwhite;
NOTEXTDEA:EMA(DIFF,N3),coloryellow;
//{数显开关:1为打开,0为关闭}
DRAWNUMBER(数显开关=1 AND LONGCROSS(DEA,DIFF,3),位置*0.8,REF(红柱面积,1)),colorred;
DRAWNUMBER(数显开关=1 AND LONGCROSS(DIFF,DEA,3),0-位置*0.5,REF(绿柱面积,1)),colorgreen;
NOTEXTLMH: DRAWNUMBER(数显开关=1 AND ISLASTBAR AND MACD>0,位置*0.8,红柱面积),colorred;
NOTEXTLML: DRAWNUMBER(数显开关=1 AND ISLASTBAR AND MACD<0,0-位置*0.5,绿柱面积),colorgreen;股票
周期放大,period,数显开关 这三个设为参数 通达信定制版面大盘走势如何添加

   看明白了你的意思了,但通达信现在的功能满足不了你的需求。 通达信定制版面如何实现上下两个窗口横轴时间一致,以及同时缩放

   通达信定制版面,每一个小版面都是相对独立的。并没有对两个窗口进行时间轴锁定的选项。
唯一有互动的是某一个版面选择了股票列表。另外两个窗口可以在点击行列表时,列出该股票的预定信息。